BSDSTATS(8) FreeBSD System Manager's Manual BSDSTATS(8)
bsdstats -- Anonymous reporting of deployment information.
The BSDstats application provides a anonymous reporting method for the
world wide accumulation of monthly statistics about the deployment of BSD
based Operating Systems. Currently the following BSD based operating sys-
tems have monthly statistics reported. (FreeBSD, OpenBSD, NetBSD, Dragon-
FlyBSD, PcBSD, and DesktopBSD). The resulting information is available
for viewing at www.bsdstats.org.
The BSDstats application has a monthly reporting period. It relies on
being run "at least" once a month for the reporting computer to be
counted. The intention here is to count computers that are currently
"using" a BSD based, not computers that ran a BSD based sometime in the
past. If you run it once and never run it again, your computer is only
included in that reporting period. It will not be included in the follow-
ing reporting periods. Multiple reporting in a period by the same com-
puter is counted as a single occurrence.
All the BSD based operating systems are open source and free of cost to
use. They are all developed by teams of volunteers without budgets for
hardware or network connections. Commercial vendors of hardware do not
consider the BSD based world as being a viable market due to the diffi-
culty in proving it's actual market share. And as such the commercial
hardware vendors refrain from investing funds for coding proprietary
drivers for their hardware to function on BSD based systems. Other Oper-
ating System vendors sell their product and as a result have a published
public annual stock holders report showing market share and this is the
ruler the commercial hardware vendors use to decide which Operating Sys-
tems to write their proprietary hardware drivers for.
Even though some large commercial business have used BSD based systems,
such as Yahoo and Microsoft, it's not in their best interest to promote
this fact. The general consensus by large commercial business with large
investments in desktop PCs and PC server farms, is that the BSD based
world is for the home hobbyist and small commercial business without a
serious information technology budget.
These view points are based on the fact that there is no money based
ruler to measure the true deployment of BSD based systems into the worlds
information technology structure.
This is where BSDstats comes in. It is the ruler that you can influence
to demonstrate to the world just how far the BSD based systems have pene-
trated into the general population of people and business using PC hard-
ware. Installing the "BSDstats Anonymous Reporting Application" on your
BSD based system can be your way of showing your voluntary support, loy-
alty, allegiance, and devotion to the BSD based you are using. You can
also think of this as demonstrating your gratitude to the developers for
the great volunteer work they have been doing.
The mere fact you are installing the BSDstats Anonymous Reporting Appli-
cation does not mean you have consciously chosen to opted-in. This appli-
cation has been designed to force the user to consciously choose to opt-
Would you like to send a list of installed hardware as well [n]?
This option reports the results of the following commands
sysctl -n hw.model
sysctl -n hw.ncpu
Would you like to send a list of installed ports as well [n]?
This option reports the results of the following command
Take note: The above 3 questions add control statements to
/etc/periodic.conf with ="YES" or ="NO" depending
on your selection.
Would you like to activate reporting on system boot [n]?
Replying "Y" will cause the (bsdstats_enable="YES") statement to
be inserted at the end of your /etc/rc.conf file so every time you
boot your system it will automatically report.
Replying "N" will cause "NO" statement to be inserted at the end
of your /etc/rc.conf file. To enable this reporting option at a
later time, you have to add this statement your self.
Would you like to run BSDstats right now [y]?
Like it says report your system right now
The normal reply to all the reporting questions is "y". In for a penny in
for a pound.
After the installation has completed you can change your reporting
options by manually hand editing the /etc/rc.conf file to remove or com-
ment out the (bsdstats_enable="YES") statement and changing the "YES" to
"NO" to disable the reporting options in the /etc/periodic.conf file, or
"NO" to "YES" to enable the reporting options in the /etc/periodic.conf
To see your first report of the month bump the website counter in real-
time execute /usr/local/etc/periodic/monthly/300.statistics -nodelay
There is a slight built in delay (5-10 minutes) as database updates are
cached to group activity to reduce the hits on the database where the
information is saved.
The BSDstats definition of Anonymous Reporting is, No information that
can be used to locate the reporting computer is saved in the BSDstats
database and all server logs are rotated and deleted every 24 hours. As
you can see from the commands executed by the different reporting
options, no personal or network identification information is being
On the first execution of the BSDstats Anonymous Reporting Application a
special hand shake between the remote server and the client is preformed
types of users, please make inquires to suggest they start reporting.
Marc G. Fournier <firstname.lastname@example.org>
Report bugs and suggestions to this email address.
FreeBSD 7.2 May 08, 2010 FreeBSD 7.2